Jump to content

Gary W. Dick

Members
  • Content Count

    6
  • Joined

  • Last visited

Everything posted by Gary W. Dick

  1. OK - after reviewing the problem William linked above - I found the issue - .ini files are somehow corrupted. The selections are there, but they're not being read. I renamed settings and preferences .ini and restarted ComicBase. Settings.ini was recreated, Preferences.ini was not. From there I renamed the fields and everything is back. Up higher I noted how my preference for backup location sometimes disappears. This is still happening even after I just did this so there appears to be an issue with how these files are handled. In my case preferences.ini does not appear to be used. One other note: In Windows 10, the AppData folder is a hidden file. Because, you, know, Microsoft. If anyone else is having this issue and wants to take a stab at it, I've attached a PDF showing what I did. ComicBase ini Files.pdf
  2. Yeah - something's not right. I've only got two custom fields and one custom check and they've all gone back to their default names; i.e. "Location" has reverted to Custom Field One. No data loss (as far as I can tell). I opened my first backup as a working file and same thing. So it would appear that assigning names to a custom field is not something that is saved and the field is not protected in any way. . . .
  3. Yes - my drive is good. But today I learned about the ALT key when exiting - that works and is better than what I did before.
  4. Mark - I'm back to normal - although there were a couple of issues. Here's what I did. Uninstall CB 2020. Ran cCleaner and cleaned up the Registry. Re-install CB 2017. Verified everything was good, then did a rebuild lists for pretty much everything and verified all good again. Re-install CB 2020. Went normally, but when I opened 2020 it didn't convert the old DB - just gave me an empty one. File/Open on the 2017 DB and it converted. Took longer than the first time. I actually have three custom fields. Custom Field 1 (Location) converted OK with all data. Custom Check 1 and Custom Field 2 did not covert to the names I had given them, but the data within these fields did convert. I reassigned the names and all is good. One other thing unrelated to the above: Backups within Setup/Preferences does not work very well. I do my backups to a removable hard drive and I only run them if there's been a DB change. Two issues: 1) I can't turn them off. 2) Where the backup goes varies. Sometimes it goes to the external hard drive, sometimes it ignores the setting and goes to the comicbase directory on the C:\ drive. When it does that, I have to reset the Preference to the external drive.
  5. Mark - I'm hoping to be able to get to that this weekend. From your earlier post I was going to re-install 2017 and run the two programs at the same time. My DBs have always been in the default location so I'm pretty confident something happened during the conversion - I've a number of books I track, and I know exactly where they are. It was just by chance I noticed the empty field. I've already made a number of additions under 2020 but I'll attempt the conversion again and let you know what happens.
  6. I too use a Custom field - Location - to identify where my books are. I converted to 2020 Professional from 2017 back in early January. I've just discovered that I have 930 books where the Location field did not convert. Many are arbitrary books in the middle of long runs that I would have no problem finding or just re-identifying, however, there are lots of others - spread out over 34 boxes - for which I have no clue. It would appear at this point my only option to is re-install 2017 (with my saved DB) to get the location field back for the missing books, then re-install 2020 (to the current DB with all the additions I've since made) and add the fields manually. Unless some has a better suggestion?
×
×
  • Create New...