Jump to content

Help with finding long/wraparound cover scans

Fred Slota

Recommended Posts

I must be missing something here.

(((I.[PictureHeight]*1000)/(I.[PictureWidth])) <= 1100) AND (I.[QtyInStock] >= 1)

returned 23 results, way less than there should be, for example missing the X-Men (2nd Series) 1/E and 1/F, the first I could think of.


Removed the QtyInStock, and added it to the OrderBy field, returned more, still the same 23 I own, and still missing many, many, including the above X-Men covers.


Build 3599

I have already run Optimization and Rebuild All Lists, including pictures.

I'm pointing at the official ComicBookScans directory.




Possible hint...    I don't think I see any Marvel or DC, and possibly Dark Horse or Image.   Is it populating the database with data from the deeper ordered titles?

Link to comment
Share on other sites

Not sure what you formula is doing but this seems to work for me.

Note: I am multiplying Height and Width by 1.0 because the columns seem to be defined as Integer (no decimal value) and Integer / Integer results in an integer value. By multiplying by a decimal, it turns all the output into decimal.

I.[QtyInStock] >= 1 AND  ( I.[PictureWidth] * 1.0)  / ( I.[PictureHeight] * 1.0) > 1

Also, there are some books that are wider than they are high and are not wraparound or gate-fold which will also show up with this query.

If you want to fine tune it a little, you can change > 1 to something like 1.2 to control how much wider than high the cover is.

Link to comment
Share on other sites

My math was getting 3 decimals of fractional precision out of integer math.


I ran your version, and I'm getting the same results.

I did a search looking for owned issues with PictureWidth > 1, and definitely no DC, Marvel, or Image, but yes for Dark Horse....


I've been doing all this on my tower, which I just updated the software, database and picture stores as a backup from my laptop.  I had reperformed all the list processings after the updates.  I tried running a similar search on my laptop, and it finds everything.


I think that the picture index process is not operating to completion on the tower.  I'll try the list rebuild again and try to pay more attention.  I can say, I did not see any error messages pitched when I previously performed it.

Link to comment
Share on other sites

Book Pictures processed through 2244...

Comic Pictures - 878799...1%...5%...

Most of the time, processing runs at a rate where I can visibly follow the progression in the 10's digits.  Occasionally, it runs at rates visible at the 100's or even 1,000's.

10%...20%...25%...50%...85%... done

The same search now appears to find everything.


As I was watching it go, I had to keep waking the screen up, which got me thinking...

I think the past couple days when I ran this overnight, my power save would kick in 3 hours into the process, interrupting the process without warning or error.  This time, I was watching it, and part-way through I changed my power settings to prevent it from cutting out.

I'm guessing that the picture scan process runs in two parts because of the two types of file structures, with all the single-layer pictures run first, then the four deeper trees, and that my PC was shutting down early into the processing for those.


Well, now I know,.  And knowing is half the battle...

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...