Jump to content

All Data in Custom Fields Deleted After DB Fix


Greg Saladino
 Share

Recommended Posts

So I just entered a new title into ComicBase 2020, and I entered some title specific data.  Then I realized that I has it classified incorrectly (I entered it as a book when it should have been a comic).  So I selected Edit > Change Title Media Type and selected Comic.  This process took a couple minutes to complete.  When it was done, I then added additional issue data.  (I noticed that the cover date field was blank, when I know that I entered a date when I had this item stored as a book.)  Then I selected the previous title using the left arrow in the top right of the screen, and I was then given an error stating "It looks like there's an invalid date that snuck into one of the date fields for this title.  Fix it now?".  I selected no, closed the application and restarted it, and I was still getting the same error whenever I tried to navigate to a title.  (However, the original title that I had entered that started this problem still displayed correctly.)  Finally, I selected "Yes" to fix the data.  The process took about 10-13 minutes.  I then went to enter another issue, when I noticed that ALL of my data from ALL the custom fields was gone.  I assume that this happened during the "fix".  I made a backup of the database before I fixed it, but it's useless as I can't navigate to any titles.  When I open the backup, I get an unhandled exception error "String was not recognized as a valid Date Time".  I can continue past the error, but I continue to get the "invalid date snuck in" error.

Please don't tell me that my data in the custom fields is lost.  

Let me know if you need any additional information.

Regards, 

Greg

Link to comment
Share on other sites

Hey Greg, do you a backup copy of your db before this trouble happened that you can load in? If you don't have one locally on your computer, check your online account as you might have backup that you can fall back on here: https://www.comicbase.com/mycb/MyBackups.aspx

If you can get back to a state where you're good, i'd be curious if you can recreate the trouble with exacts steps so we can try them out on our end. If you found some sort of bug; we definitely want to get it addressed.

Link to comment
Share on other sites

I have a backup from early December (probably the last time that I closed ComicBase), but I've entered and updated at least a couple hundred records since then. 

I attempted to download the backup at the link provided, but I get an HTTP 403: Access Denied error.

I'm fairly certain that I can recreate the problem, as it had happened earlier when I first upgraded to CB2020 in early December, but since I had been using it for less than a day, I just reloaded the old CB2011 database and started fresh.  I will attempt to recreate this error when I have some free time later tonight.

Would it possible to send you a copy of the non-working database so that it can be looked into and possibly fixed manually?  

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...