Jump to content

Crystal Reports error


Scott Nass
 Share

Recommended Posts

Followed the attached instructions except there were no instances of SAP Crystal Reports on my machine.  Reinstalled and still having the same error whenever I try to prepare any reports.  Program otherwise working fine before and after the reinstall.  Can someone please advise? 

 

image.png.21b44b08c424f28802c8b5dd7987e698.png

Link to comment
Share on other sites

Do the Following:

Go into your Windows Start Menu>Settings>Applications

-uninstall your CB2022 edition

-uninstall your CB2022 resource listing

-uninstall your SAP Crystal Report listing (you noted you 'installed' it in your initial post)

-lastly, download/install the revised CB2022 program installer from your online account here:

https://www.comicbase.com/mycb/Registrations.aspx

Link to comment
Share on other sites

  • 4 weeks later...

Sorry, Mark, didn't have notifications on.  Thanks for the reply!

Clarifying, I neither installed nor uninstalled SAP Crystal Report - it was CB2022 I reinstalled.  There is no evidence of SAP Crystal Report on my machine either before or after installing CB2022.  Other than that line, I have followed your instructions to the letter twice now with no change to outcome.

What other information can I provide that would be helpful to figuring this out?

Link to comment
Share on other sites

If you don't see the SAP Crystal Reports component listed in your Windows application list after installing CB2022, you may have some sort of protection software blocking it.

Alternatively, here's a separate link to get that SAP Crystal Reports component installed if you need it:

https://www.dropbox.com/s/i32i9dalm9ix2lc/CRRuntime_32bit_13_0_31.msi?dl=0

after installing it, try to run a report and see if it produces.

Link to comment
Share on other sites

  • 3 weeks later...

Windows 10 Home, 64-bit

Other than browser pop-up and tracker blockers, I'm only running Windows Security on the system.

But your final suggestion worked.  The installer must have detected SAP Crystal Reports on my machine (although I can't find anything with any part of that name when searching the hard drive) because running the installer gave me the options to remove or reinstall.  I "reinstalled" and after restarting CB, all is well.  

HUGE thanks, @Mark J. Castaneda!

Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
 Share

×
×
  • Create New...