Jump to content
Fred Slota

Help for Search for Issues missing pictures

Recommended Posts

I've pointed the system at my personal cover scan directory tree, and that works, I see them in the program.

I rebuilt all Lists, including picture files.

I search for I.[PictureFileSize] is less than or equal 1000, List only items in stock, and am told no matching items were found.  Same for greater than or equal 1000.  Same thing for all issues, not just in stock.

Same thing for PictureHeight and PictureWidth.

 

 

I tried Advanced Search for I.[QtyInStock] > 0, sort by I.[PictureFileSize] with Max Results to 30000, and this looks promising.  21,848 results, showing 5,000 at a time.  But...  When I click the arrow to see the next 5,000, the numbers change, but the issue grid does not update-I still see the same 5,000 issues.

 

So, I've got the following...

1) Searching in Picture fields don't appear to work.

2) Searches of more than 5,000 are not viewable

3) I still don't have the information I wanted to have.

 

Share this post


Link to post
Share on other sites

What version of CB are you using?

A new version (v3599) was just posted today.

Until this version, using File Tools->Rebuild lists and checking the box regarding pictures actually didn't work.  This have been fixed with the newest version.

I have downloaded / installed this and am currently running the process which will take a LONG time. How long depends on where you pictures are located and how many you have. I have mine on an M2 drive which should run faster than if on a Solid State Drive which should be faster than on a regular hard drive.

Once this has completed, the various Picture columns 'should' be updated and then your Finds should work (at least I hope so...).

Share this post


Link to post
Share on other sites

After about 1 hour , the Pictures files list rebuild completed. 

After that an Advanced Find using:

I.[QtyInStock] >= 1 AND I.[PictureHeight] IS NULL

Seems to have found Items I own that do not have a picture.

 

 

Share this post


Link to post
Share on other sites

By the way, on my computer, I ran into a problem when displaying a Find result that has more items than rows to display in a Grid (causing the < number - number > at the bottom of the page).  For now, to get around that, you can use Preferences to set Rows to display in Grid to more than 5000 (I have mine set to 100000).

Share this post


Link to post
Share on other sites

Searched for the Item Field PictureFileSize IS NULL showing only Items in stock, and it found nothing.   Same for <100.   Same for all items.

 

Advanced Find Qty and FileSize does work.

 

 

Share this post


Link to post
Share on other sites

Hmm... The only thing I can think that I might have done differently is I ran Optimize Database after the Rebuild Lists Picture info.

Since the Picture columns can't be displayed, I have to determine what is stored there.

Using The Phantom (1st Series) #3.jpg as a test, multiple finds with Between shows the value for this is 3149.

This matches the Property values for the file which has the value for Size: 3.07 KB (3,149 bytes).

So try using Byte values instead of KB values.

Keep in mind that if NULL is stored there NULL is not < (or equal) to anything.

 

Share this post


Link to post
Share on other sites

Thanks Steve for letting Pete (our lead programmer) know via Slack what's going on with this one. He mentioned this one a bit more complex... we hope to figure things out in the coming days.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...