Jump to content

Drag and Drop covers not working in CB2021?

Jeff Egan

Recommended Posts

Pardon if I missed this somewhere... I just downloaded and updated to v21.0.0.1218 and can no longer drag and drop covers from Windows into Comicbase.  I've tried restarting Comicbase, rebooting my computer, and a hard shutdown of the computer. I don't get an error message, just a circle with a line through it symbol on the Comicbase cover image when I try to drag my image over the existing one.

Thanks in advance!

Link to comment
Share on other sites

More info if it helps... I know it worked prior (last night) to the upgrade (this morning).

Things that I've tried...

  1. Ensuring that CB is being run with administrator privileges
  2. In-place Repair using the CB2021 setup
  3. Opening a different database
  4. Starting a new database
  5. Opening my normal database (after going through all the above)

And I'm not able to drag and drop into any of the databases.

System Info

  • OS: Windows 10 Pro x64 [Windows 10.0.18362 Build 18362]
  • CPU: Ryzen 5 
  • RAM: 32GB physical

Thanks for the help.

Link to comment
Share on other sites

Yessir. I've tried making new scans and using older scans that worked with the previous version; all JPGs.

I can add/overwrite existing files if I manually copy them directly into the folders below the Pictures directory (e.g. \Pictures\V\Valiant\Eternal Warrior).

And I will email support. Appreciate your help.

Link to comment
Share on other sites

Hey Mark - thanks for reaching out.

Literally, I was updating inventory in CB2020 that night. When I started CB up in the morning, it showed the update as available.  I let CB download and install. The install then downloaded a boatload of resource files and when I started CB2021, I was no longer able to do the same drag-and-drop I've been doing for weeks.

I hadn't even turned my PC off. No changes in HW or SW that I'm aware of. Since going through the steps mentioned above, I've also uninstalled CB2021 and reinstalled CB2020. Same problem.  I reinstalled CB2021 over that and still have the same problem.  Went back through the reboot/shutdown operations, no change.  I've tried old images from different drives and new scans, same result.

What I did notice is that uninstalling CB2021 does not remove all the new files.  It looked to have pulled nearly all the files from the program directory, but the new screensaver was still operational afterward.  I don't think the screensaver is the problem 😉  I''m just noting that some files changed that the uninstall didn't uninstall.  I'm wondering if any files were added or overwritten in the Windows System or System32 directories that might have changed the behavior, but I have no clue what controls the drag-and-drop behavior.  Outside of CB, the other apps that I've tried to drag-and-drop with have all worked as expected.

I did receive an email from support that they didn't have any trouble either.  Peter offered a remote session, but my bandwidth generally doesn't handle those well.

I've still got some things to try I think. I'll uninstall again and reinstall CB2020, then overwrite those files from a backup and see what happens.  I'm open to any other suggestions.  Knowing and loving Windows as I do, the problem may disappear after a random number of reboots... especially if no one else is reporting a similar problem.

Thanks again!

Link to comment
Share on other sites

Should have asked before...

  1. Better to run the install FROM the original CB program folder?  Or from a completely different directory?
  2. Better to install TO a completely new location?  Or back into the same directory where I had CB installed before?



Link to comment
Share on other sites

No joy installing it to the default directory (Program Files (x86)).  I had my fingers crossed and everything too.

There are 2 directories under C:\Program Files (x86)\Human Computing\:

  • ComicBase 2021 4K  Archive Edition
  • ComicBase 2021 Resources

but the ComicBase 2021 Resources directory is empty. No files at all, hidden or otherwise.  Is that correct?

Link to comment
Share on other sites

My Resources directory is also empty, so that appears normal.

NOTE: not sure if is a typo but my other folder is just ComicBase 2020 Archive Edition (with out the 4K even though I DO have 4K Archive installed.

The last thing I can thing to try (and you may have already done this), is

Uninstall CB 2021.

Reinstall CB 2020.

From inside CB 2020, use menu item Internet->Check for Updates and let it download/install from there.

If that doesn't work, you may have to let HC remote to your computer (if at all possible) as there is something very strange going on.


Link to comment
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
  • Create New...