Jump to content
Cyberspace Steve

Titles take a long time to load after clicking "Titles" button

Recommended Posts

After clicking the "Titles" button, the pop-up search doesn't appear for four seconds. Selecting "Titles in Stock" shaves off about 2 seconds but I'm not interested in limiting my searches to just titles I already have. Is there any way to speed up this process?

 

 

Share this post


Link to post
Share on other sites

Just to be clear...

When you enter into the Title List (Ctrl+T), then check in 'Titles in Stock' you experiencing a few second delay as you enter/pick these options?

I don't run into that kind of delay on my computer. Anyone else experience this kind of delay?

Share this post


Link to post
Share on other sites

When I use Ctrl+T, there is about a 3 second delay for all Titles

For Titles I own, it is less than 1 second.

This is both before and after Rebuild Lists->Series Information and Optimize Database.

Share this post


Link to post
Share on other sites

Mark, if I click the "Titles" button (located at top right), I experience about a 4 second delay.

 

If I change my option to "titles in stock", then close out of the title search box ... I experience approximately a 2 second delay when I click the "Titles" button. However, it's worth noting that I never narrow my search this way ... I just wanted to see if this would affect the speed.

 

 

my specs:

processor - intel Core i7-5500U CPU @ 2.40GHz
Installed RAM - 8.00 GB
system type - 64 bit

Share this post


Link to post
Share on other sites

What you're facing is the sheet amount of time it takes to load (Steve, in your case) tens of thousands of items into a list. Short of getting a faster computer, or trimming your comic collection, I'd suggest simply avoiding the issue entirely: use the main title browse instead-- it's essentially instantaneous to load the 500 matching entries to whatever you type into that list. The only time I'd use the Titles browse window is when I explicitly _wanted_ to see the list of all the titles in the database.

 

-Pete

Share this post


Link to post
Share on other sites

FWIW: It's about 2 second wait on my machine (a 3.6 GHz i9). The bigger difference for this -- and most other things database related -- is that I'm using an NVMe SSD, which takes disk access time essentially to zero in most cases. 

If you haven't tried them yet (and your motherboard supports them), these are probably the single biggest speed-up for a computer today:

https://www.amazon.com/Samsung-970-EVO-SSD-1TB/dp/B07BN217QG?psc=1&SubscriptionId=AKIAILSHYYTFIVPWUY6Q&tag=duckduckgo-brave-20&linkCode=xm2&camp=2025&creative=165953&creativeASIN=B07BN217QG

 

-Pete

Share this post


Link to post
Share on other sites

Thanks for the heads up, Peter. I'll start using the "FIND" search bar instead. That's helping me navigate much faster.

Edited by Cyberspace Steve

Share this post


Link to post
Share on other sites
On 1/16/2020 at 12:15 PM, Peter R. Bickford said:

What you're facing is the sheet amount of time it takes to load (Steve, in your case) tens of thousands of items into a list. Short of getting a faster computer, or trimming your comic collection, I'd suggest simply avoiding the issue entirely: use the main title browse instead-- it's essentially instantaneous to load the 500 matching entries to whatever you type into that list. The only time I'd use the Titles browse window is when I explicitly _wanted_ to see the list of all the titles in the database.

 

-Pete

Using the main title browse field has allowed me to start using ComicBase again, so thank you very much for that tip!

I have just over 3,000 comics entered into my CB.  When I was using 2017, there was a little delay when I used the Title Browse to skim through all the titles, but CB never crashed when I used it.  When I first went to 2020, the Title Browse  rendered CB pointless.  It crashes to desktop, it locks up for an hour, most of the time it just took 10 45 seconds to respond to any input, and very rarely it would work smoothly. 

Since I found your above tip, CB has become enjoyable again.  As long as I don't use the Title Browse window.  I have also found that the back and forward arrows bracketing the Title Browse button work fine, another great plus.

My disk I/O is never more than 5%, RAM stays at 4.5/24Gb, and CPU ranges from 30% to 75%.  

Please don't get me wrong, I love this program and I have no intention of not using it for the foreseeable future.

I'm happy to get you any info I can to help CB work better.

 

Thanks,

Pat

Edited by Patrick O’Malley
to check the receive update on replies.

Share this post


Link to post
Share on other sites

I'd be curious as to what your experience would be if you booted with all your extensions turned off (other than the Microsoft ones) -- I wonder if you might have something running (anti-virus? security suite?) which is compromising your performance to this extent.

 

Share this post


Link to post
Share on other sites
On 2/14/2020 at 1:09 AM, Peter R. Bickford said:

I'd be curious as to what your experience would be if you booted with all your extensions turned off 

It would run like it was meant to.  That is what would happen if I booted with all my extensions off.

Yay!!!  It's my computer!  I have been working on networks too long.  I didn't even think of doing a safeboot.  

I will post the culprit once I have identified it.

Thank you, Peter!

Share this post


Link to post
Share on other sites

I tried using the search bar and it doesn't find titles, only characters, even though "find" is set to "Title name or barcode."

Furthermore, when I start to type a name, only a few selections come up.  For example, entering "night" only brings up "Nighthawk (Kyle Richmond)" and "Nightwing (Superman)".

Share this post


Link to post
Share on other sites

Scott: make sure you're running the current build (308x), and that you explicitly choose the Find > Title name or barcode option from the drop-down. If you still have problems afterward, contact support directly at 408-266-6883

 

Best,

-Pete

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×
×
  • Create New...